FREE SHIPPING FOR ORDERS OVER $100 IN CANADA or $125 IN THE US.

Repair – Rewire the Hub Connectors – Anycubic I3 Mega S





Transcript

Hello everybody and welcome to another build video. Today we’ll see just how difficult rewiring the cables to bypass the hub controls might be. Unfortunately for me this change was a necessity since there was an issue with the connections from my machine. I’ve tried almost everything at this point, so this is essentially my last resort. Please undertake these modifications at your own risk.

Before begging this mod, I made sure to get some wiring diagrams ready and the good news is that the community has done a great job of posting this information online. I found these two diagrams by doing a quick google search. I got the diagrams for both the hub connection and the motherboard and this was very crucial to troubleshooting issues as they arose. In the end I didn’t need to purchase too many materials to do these upgrades however I was lucky enough to already have most of the tools on hand before starting this project. I will make sure to include a list in the description below for anyone who may which to try and undertake this in the future.

Before starting to remove anything withing the machine, I made sure to take a couple of photos of where everything was located just in case I ran into issues latter on. Every time I disconnected something, I make sure to label the cable immediately. Doing this helped save me quite a bit of time and made it easier to follow the wiring diagrams. Very important to note, is the fact that I had already installed mosfets as an added buffer for the current going through the motherboard.

When beginning to dissemble the machine I made sure to start with the hot end assembly. There are two screws on the top and two lower ones in the back which help hold the cover into place. After removing those I was able to unscrew the hot end hub. When I made my most recent modification, I had added some hot glue to help hold the connections in place because they were prone to coming to lose. Once this was removed, I was then able to disconnect the wires.

When I disconnected the Z-motors, I had the option to either cutting or unscrewing the end stops. I personally wanted to add some longer cables, so I ended up cutting them instead. I removed the connections from the main hub and began preparing the wires. Since these wires were already the correct length in most cases, I simply reused them by cutting off the connectors and separating the wires.

Before starting this project, I made sure that I had plenty of extra connectors available to help ensure that I didn’t run out halfway through. I’ve found that using pliers to temporarily tighten the pin made it easier to crimp together. By including some of the protective coating it helped to add quite a bit of extra support to the connections. Any exposed wire was insulated using transparent shrink tubing to make it easier to see any problems should they come up. With the tweezers that came with the printer, I was often able to push in any pins that weren’t fully inserted which helped to reduce any waste. When trying to get the correct wires lined up, I loosely attached the connector to the opposing side so that I could match the wiring more easily. Before adding any solder, I always use some flux to help prepare the area and ensure a better connection. Pre-tinning the wires before soldering, also made it easier to get a proper connection.

Most of the connections are pretty straight forwards, however there was one area which shared a common connection point for the ground wires. To allow me to troubleshoot and make changes easier in the future, I joined the ground wires together and then added a separate connector to the remaining wires. While this may clutter the inside of the machine more, it does make it easier to troubleshoot issues down the road or make upgrades.

With the wiring done it was finally time to do some quick cable management so by re-using the same cable wraps as before I was able to do this portion fairly quickly. By looking at the initial photos I had taken, I was able to get an idea of how they were originally placed and tried my best to replicate the same format. Before closing up the hot end assembly I ran a quick test to make sure everything was still working movement wise. Although I don’t have the footage, I did discover that with the firmware upgrade I had made, I needed to change the motherboard connection of the Z-Axis to the secondary Z-axis slot. Once I did this, the secondary Z-Axis homed correctly, and I didn’t have any further issues with that portion. In my case, I did run into one more issues in that the ceramic heater cartridge for my extruder was malfunctioning because the wire had come loose. Once I repaired this, the machine was finally able to complete its first print.

So would I recommend doing this to your machine? Well, no not unless it absolutely necessary. It took around 3 days to complete this modification and I did run into additional issues along the way. If your machine is constantly giving you issues and is no longer within it’s warranty then this is perhaps worth doing as a result. Unlike upgrading the firmware, which you can see in this video here, it isn’t necessary unless it’s broken. Now Because I’m not entirely happy with the lack of cable supports. That will be another video for the future but if you want to try this as well, I’ve included some important links in the description below.